Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

Tentative de flashage sur Rpi3

12

Je continue dans l'install de la PiZigate.

Suite à des erreurs dans les logs (voir post de Martial), je tente de flasher ma pizigate; voici les logs.

$ git clone https://github.com/Jerome-PS/JennicModuleProgrammer.git
Cloning into 'JennicModuleProgrammer'...
remote: Enumerating objects: 54, done.
remote: Total 54 (delta 0), reused 0 (delta 0), pack-reused 54
Unpacking objects: 100% (54/54), done.
$ cd JennicModuleProgrammer/
~/JennicModuleProgrammer$ cd Build/
~/JennicModuleProgrammer/Build$ make
cc  -I. -Wall -O2 -I../Source/ -DDBG_ENABLE -DVERSION="\"56124\"" -c ../Source/uart.c
cc  -I. -Wall -O2 -I../Source/ -DDBG_ENABLE -DVERSION="\"56124\"" -c ../Source/JN51xx_BootLoader.c
../Source/JN51xx_BootLoader.c:1182:12: warning: ‘iBL_WriteRAM’ defined but not used [-Wunused-function]
static int iBL_WriteRAM(int iUartFd, uint32_t u32Address, uint8_t u8Length, uint8_t *pu8Buffer)
^~~~~~~~~~~~
../Source/JN51xx_BootLoader.c:1104:12: warning: ‘iBL_RunRAM’ defined but not used [-Wunused-function]
static int iBL_RunRAM(int iUartFd, uint32_t u32Address)
^~~~~~~~~~
cc  -I. -Wall -O2 -I../Source/ -DDBG_ENABLE -DVERSION="\"56124\"" -c ../Source/Firmware.c
cc  -I. -Wall -O2 -I../Source/ -DDBG_ENABLE -DVERSION="\"56124\"" -c ../Source/main.c
../Source/main.c: In function ‘main’:
../Source/main.c:114:9: warning: variable ‘iVerify’ set but not used [-Wunused-but-set-variable]
int iVerify = 0;
^~~~~~~
cc  uart.o JN51xx_BootLoader.o Firmware.o main.o   -o JennicModuleProgrammer
~/JennicModuleProgrammer/Build$ wget https://github.com/fairecasoimeme/ZiGate/releases/download/Release/ZiGate_v30f.bin
--2019-04-04 11:44:15--  https://github.com/fairecasoimeme/ZiGate/releases/download/Release/ZiGate_v30f.bin
Resolving github.com (github.com)... 140.82.118.3, 140.82.118.4
Connecting to github.com (github.com)|140.82.118.3|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://github-production-release-asset-2e65be.s3.amazonaws.com/106914975/c55eb600-2d21-11e9-9678-cc369b006517?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20190404%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20190404T094415Z&X-Amz-Expires=300&X-Amz-Signature=e05ff7449c773539ff939d875d9d47c930b08c0d49fdedf21443e8fc0ea1c9a6&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3DZiGate_v30f.bin&response-content-type=application%2Foctet-stream [following]
--2019-04-04 11:44:15--  https://github-production-release-asset-2e65be.s3.amazonaws.com/106914975/c55eb600-2d21-11e9-9678-cc369b006517?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20190404%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20190404T094415Z&X-Amz-Expires=300&X-Amz-Signature=e05ff7449c773539ff939d875d9d47c930b08c0d49fdedf21443e8fc0ea1c9a6&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3DZiGate_v30f.bin&response-content-type=application%2Foctet-stream
Resolving github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)... 52.216.233.27
Connecting to github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)|52.216.233.27|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 203388 (199K) [application/octet-stream]
Saving to: 'ZiGate_v30f.bin'

ZiGate_v30f.bin                                 100%[=====================================================================================================>] 198.62K   596KB/s    in 0.3s

2019-04-04 11:44:16 (596 KB/s) - 'ZiGate_v30f.bin' saved [203388/203388]
binerf@rasphab:~/JennicModuleProgrammer/Build$ sudo /home/domoticz/plugins/Domoticz-Zigate/Tools/pi-zigate.sh flash
Switching PI-Zigate to Flash mode
~/JennicModuleProgrammer/Build$ ./JennicModuleProgrammer -V 6 -P 115200 -f ZiGate_v30f.bin -s /dev/ttyAMA0
JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Error setting baudrate

J'ai encore dû zapper un truc...

J'ai exactement le même problème.

Voir mon post avec la solution de mes messages d'erreur

Bonjour,

j'ai exactement le même problème aussi

j'ai supprimé console=serial0,115200 de /boot/cmdline.txt

cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=8915ef90-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

dans /boot/config.txt j'ai rajouté

#disable bluetooth
dtoverlay=pi3-disable-bt
enable_uart=1

 

ls -l /dev
lrwxrwxrwx 1 root root           7 avril  6 14:17 serial0 -> ttyAMA0
lrwxrwxrwx 1 root root           5 avril  6 14:17 serial1 -> ttyS0

sudo ./JennicModuleProgrammer -V 255 -P 115200 -f /home/pi/ZiGate_v30f.bin -s /dev/serial0
JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Error setting baudrate

sudo ./JennicModuleProgrammer -V 255 -P 115200 -f /home/pi/ZiGate_v30f.bin -s /dev/ttyAMA0
JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Error setting baudrate

@martialandre as tu trouvé une solution?

 

merci d'avance

Bonjour,

Non, je n'ai pas trouvé de solution à ce problème, mais j'ai résolu mon problème de départ sans reflasher.

Il fallait faire un Erase Persistant Data à l'aide du plugin (je suis avec le plugin Domoticz, merci @pipiche)

Cordialement

Bon, j'ai tenté d'intégrer d'autres modules via la PiZiagte ce soir mais dans les logs, je suis tombé sur cette erreur:

[...]

2019-04-08 22:13:52.943  Error: (PiZigate) onHeartbeat receive, but no connection to Zigate

[...]

Du coup, j'ai tenté de supprimer la Zigate de la conf domoticz pour la recréer mais depuis, je n'arrive plus à avoir l'interface web domoticz (timeout) et dans les logs de domoticz j'ai toujours le même message d'erreur:

[...]

2019-04-08 22:13:52.943  Error: (PiZigate) onHeartbeat receive, but no connection to Zigate

[...]

J'ai retenté de flasher et là, ça fonctionne:

./JennicModuleProgrammer/Build# ./JennicModuleProgrammer -V 255 -P 115200 -f ZiGate_v30f.bin -s /dev/ttyAMA0
JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Detected Chip: Unknown
MAC Address:   00:15:8D:00:01:ED:47:37
Opened firmware file size 203388
Module uses Bootloader v2 Header
Erasing:   100%
Writing Program to Flash
Writing:   100%
Verifying Program in Flash
Verifying: 100%
Success
./JennicModuleProgrammer/Build#

Mais toujours le même message d'erreur et impossible de me reconnecter a Domoticz.

Là, c'est la déprime en me disant qu'il faut tout réinstaller....

Bon, je viens de retirer physiquement la PiZigate de mon rasp.

Après reboot du rasp, Domoticz est de nouveau accessible. Du coup, j'ai supprimé la PiZigate de la config.

Ensuite, si je rebranche la PiZigate dans le rasp et que je redémarre, c'est de nouveau la cata (message d'erreur et domoticz inaccessible (ca fait tomber la partie ssl on dirait)).

Bref, pour le moment, la PiZigate, c'est pas très stable :`(

Allez, on continue un peu de creuser.

Maintenant, la zigate semble OK (me demandez pas comment) mais tous les devices créés auparavant n'apparaissent plus dans les devices sous Domoticz exceptés les nouveaux.

Pour test, j'ai un bouton Xiaomi (le rond sur pile), quand j'appuie dessus, j'ai dans les logs:

[...]

2019-04-08 23:18:21.278  (PiZigate) Received 8 bytes of data
2019-04-08 23:18:21.278  (PiZigate) Received 8 bytes of data
2019-04-08 23:18:21.278  (PiZigate) Received 8 bytes of data
2019-04-08 23:18:21.278  (PiZigate) Received 8 bytes of data
2019-04-08 23:18:21.278  (PiZigate) Received 1 bytes of data
2019-04-08 23:18:21.279  (PiZigate) ZigateRead - decoded data : 018102000ed843d7f3010006000000100001002403 lenght : 42
2019-04-08 23:18:21.280  (PiZigate) ZigateRead - MsgType: 8102, MsgLength: 000e, MsgCRC: d8, Data: 43d7f301000600000010000100; RSSI: 24
2019-04-08 23:18:21.280  (PiZigate) ZigateRead - MsgType 8102 - Report Individual Attribute response : 018102000ed843d7f3010006000000100001002403
2019-04-08 23:18:21.280  (PiZigate) Decode8102 - Individual Attribute response : [d7f3:01] ClusterID: 0006 AttributeID: 0000 Status: 00 Type: 10 Size: 0001 ClusterData: >00<
2019-04-08 23:18:21.280  (PiZigate) DeviceExist - Found in ListOfDevices with status = inDB
2019-04-08 23:18:21.280  (PiZigate) Decode8102 : Attribute Report from d7f3 SQN = 43 ClusterID = 0006 AttrID = 0000 Attribute Data = 00
2019-04-08 23:18:21.281  (PiZigate) Not the good Domoticz level for Touch
2019-04-08 23:18:21.281  (PiZigate) Device : d7f3 MacCapa : 80 updating SQN to 43
2019-04-08 23:18:21.281  (PiZigate) updSQN - Device : d7f3 updating SQN to 43
2019-04-08 23:18:21.281  (PiZigate) ReadCluster - MsgData lenght is: 26 out of 24+
2019-04-08 23:18:21.281  (PiZigate) DeviceExist - Found in ListOfDevices with status = inDB
2019-04-08 23:18:21.282  (PiZigate) ReadCluster - 0006 NwkId: d7f3 Ep: 01 AttrId: 0000 AttyType: 10 Attsize: 0001 Status: 00 AttrValue: 00
2019-04-08 23:18:21.282  (PiZigate) MajDomoDevice - Device ID : 00158d00021016ae - Device EP : 01 - Type : 0006 - Value : 00 - Hue :   - Attribute_ :
2019-04-08 23:18:21.282  (PiZigate) ClusterSearch - Cluster: 0006, ProfileID: , ZDeviceID: , create: False
2019-04-08 23:18:21.282  (PiZigate) MajDomoDevice - Type = Switch
2019-04-08 23:18:21.282  (PiZigate) ReadCluster - ClusterId=0006 - reception General: On/Off: 00
2019-04-08 23:18:21.483  (PiZigate) Received 8 bytes of data
2019-04-08 23:18:21.483  (PiZigate) Received 8 bytes of data
2019-04-08 23:18:21.483  (PiZigate) Received 8 bytes of data
2019-04-08 23:18:21.483  (PiZigate) Received 8 bytes of data
2019-04-08 23:18:21.483  (PiZigate) Received 1 bytes of data
2019-04-08 23:18:21.484  (PiZigate) ZigateRead - decoded data : 018102000ede44d7f3010006000000100001012403 lenght : 42
2019-04-08 23:18:21.485  (PiZigate) ZigateRead - MsgType: 8102, MsgLength: 000e, MsgCRC: de, Data: 44d7f301000600000010000101; RSSI: 24
2019-04-08 23:18:21.485  (PiZigate) ZigateRead - MsgType 8102 - Report Individual Attribute response : 018102000ede44d7f3010006000000100001012403
2019-04-08 23:18:21.485  (PiZigate) Decode8102 - Individual Attribute response : [d7f3:01] ClusterID: 0006 AttributeID: 0000 Status: 00 Type: 10 Size: 0001 ClusterData: >01<
2019-04-08 23:18:21.485  (PiZigate) DeviceExist - Found in ListOfDevices with status = inDB
2019-04-08 23:18:21.485  (PiZigate) Decode8102 : Attribute Report from d7f3 SQN = 44 ClusterID = 0006 AttrID = 0000 Attribute Data = 01
2019-04-08 23:18:21.486  (PiZigate) Not the good Domoticz level for Touch
2019-04-08 23:18:21.486  (PiZigate) Device : d7f3 MacCapa : 80 updating SQN to 44
2019-04-08 23:18:21.486  (PiZigate) updSQN - Device : d7f3 updating SQN to 44
2019-04-08 23:18:21.486  (PiZigate) ReadCluster - MsgData lenght is: 26 out of 24+
2019-04-08 23:18:21.486  (PiZigate) DeviceExist - Found in ListOfDevices with status = inDB
2019-04-08 23:18:21.487  (PiZigate) ReadCluster - 0006 NwkId: d7f3 Ep: 01 AttrId: 0000 AttyType: 10 Attsize: 0001 Status: 00 AttrValue: 01
2019-04-08 23:18:21.487  (PiZigate) MajDomoDevice - Device ID : 00158d00021016ae - Device EP : 01 - Type : 0006 - Value : 01 - Hue :   - Attribute_ :
2019-04-08 23:18:21.487  (PiZigate) ClusterSearch - Cluster: 0006, ProfileID: , ZDeviceID: , create: False
2019-04-08 23:18:21.487  (PiZigate) MajDomoDevice - Type = Switch
2019-04-08 23:18:21.487  (PiZigate) ReadCluster - ClusterId=0006 - reception General: On/Off: 01
[...]

Mais je ne le retrouve pas dans l'interface de Domoticz. Une idée du pourquoi ?

Allez, quelques news.

Depuis que j'ai purgé les fichiers DeviceList-13.txt* dans /home/domoticz/plugins/Domoticz-Zigate/Data et relancé l'ensemble, j'arrive à intégrer tous mes modules Zigbee.

J'ai juste une erreur qui pollue mes logs de domoticz:

2019-04-11 10:59:30.122  Error: (PiZigate) 'onHeartbeat' failed 'KeyError'.
2019-04-11 10:59:30.122  Error: (PiZigate) ----> Line 618 in /home/domoticz/plugins/Domoticz-Zigate/plugin.py, function onHeartbeat
2019-04-11 10:59:30.127  Error: (PiZigate) ----> Line 498 in /home/domoticz/plugins/Domoticz-Zigate/plugin.py, function onHeartbeat
2019-04-11 10:59:30.127  Error: (PiZigate) ----> Line 418 in /home/domoticz/plugins/Domoticz-Zigate/Modules/heartbeat.py, function processListOfDevices
2019-04-11 10:59:30.127  Error: (PiZigate) ----> Line 759 in /home/domoticz/plugins/Domoticz-Zigate/Modules/output.py, function processConfigureReporting

Une idée de comment fixer ce problème ?

Bonjour,

il faut que tu poses ton problème sur le forum approprié :

https://easydomoticz.com/forum/viewforum.php?f=28

Tu auras plus de retour 🙂

Bonjour,

Hier  j'ai  mis à jour le firmware (https://zigate.fr/documentation/mise-a-jour-de-la-zigate/) de mon module  USB-TTL  Prolific (bleu) qui fonctionne avec mon Jedoom sur un PI3 (Linux raspberrypi 5.4.83-v7+ #1379 SMP Mon Dec 14 13:08:57 GMT 2020 armv7l GNU/Linux).

Commande :

./JennicModuleProgrammer -V 255 -P 115200 -f ./ZiGate_v3.1d.bin -s /dev/ttyUSB0

j'avais l'erreur suivante :

JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Error setting baudrate

Il a fallut que je fasse les préconisations décrites un peu plus haut (merci vincent.bastin):

  1. J'ai supprimé console=serial0,115200 du fichier /boot/cmdline.txt
  2.  dans /boot/config.txt j'ai rajouté

#disable bluetooth
dtoverlay=pi3-disable-bt
enable_uart=1

Le firmware s'est alors correctement installé.

 

Cependant, depuis le Plugging ZIGATE (version 2020-11-29 01:02:14) de mon Jedoom (V 4.1.18) ne fonctionne plus !!!

Merci de m'aider .

[2021-01-31 17:49:50][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-31 17:50:17][ERROR][zigate](MainThread) : Failed to get network state
[2021-01-31 17:50:40][ERROR][zigate](MainThread) : Failed to start network
[2021-01-31 17:50:45][ERROR][zigate](ZiGate-Listen) : OOPS connection lost, reconnect...
[2021-01-31 17:50:45][ERROR][zigate](ZiGate-Listen) : Failed to connect, retry in 1 sec...
Traceback (most recent call last):
File "/var/www/html/plugins/zigate/core/class/../../resources/zigated/zigated.py", line 336, in <module>
if version < '3.0d':
TypeError: '<' not supported between instances of 'NoneType' and 'str'


VOICI le détail en Mode Debug.
[2021-01-31 17:57:47][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-31 17:57:48][INFO] : Lancement démon zigate : /usr/bin/python3 /var/www/html/plugins/zigate/core/class/../../resources/zigated/zigated.py  --device auto --gpio 0 --loglevel debug --apikey 2ud29Zg2OUuajd4gvvT3F7ZDwcLWdxaS --pid /tmp/jeedom/zigate/daemon.pid --socket /tmp/jeedom/zigate/daemon.sock --callback http://127.0.0.1:80/plugins/zigate/core/php/jeeZiGate.php --sharedata 0 --enable_led 0
[2021-01-31 17:57:49][INFO][root](MainThread) : Start zigated
[2021-01-31 17:57:49][INFO][root](MainThread) : Log level : debug
[2021-01-31 17:57:49][INFO][root](MainThread) : Socket : /tmp/jeedom/zigate/daemon.sock
[2021-01-31 17:57:49][INFO][root](MainThread) : PID file : /tmp/jeedom/zigate/daemon.pid
[2021-01-31 17:57:49][INFO][root](MainThread) : Apikey : 2ud29Zg2OUuajd4gvvT3F7ZDwcLWdxaS
[2021-01-31 17:57:49][INFO][root](MainThread) : Device : auto
[2021-01-31 17:57:49][INFO][root](MainThread) : Callback : http://127.0.0.1:80/plugins/zigate/core/php/jeeZiGate.php
[2021-01-31 17:57:49][INFO][root](MainThread) : Python version : 3.7.3 (default, Jul 25 2020, 13:03:44)
[GCC 8.3.0]
[2021-01-31 17:57:49][INFO][root](MainThread) : zigate version : 0.40.11
[2021-01-31 17:57:49][DEBUG][root](MainThread) : Writing PID 29871 to /tmp/jeedom/zigate/daemon.pid
[2021-01-31 17:57:49][DEBUG][root](MainThread) : Send to test to jeedom
[2021-01-31 17:57:49][DEBUG][root](MainThread) : Send to jeedom :  {'action': 'test'}
[2021-01-31 17:57:49][DEBUG] : Array (     [action] => test )
[2021-01-31 17:57:49][DEBUG][root](MainThread) : Jeedom reply :  {'success': True}
[2021-01-31 17:57:49][INFO][root](MainThread) : Démarrage ZiGate auto
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Try loading persistent file
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Trying to load /var/www/html/plugins/zigate/core/class/../../resources/zigated/zigate.json
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Load neighbours cache: [['0000', '11d0', 138], ['0000', 'ef99', 144], ['0000', '44de', 165], ['0000', 'a8dc', 100]]
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Acquire Lock on device Device  (11d0) 00158d0002d4883f
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Release Lock on device Device  (11d0) 00158d0002d4883f
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Acquire Lock on device Device  (44de) 00158d0003498459
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Release Lock on device Device  (44de) 00158d0003498459
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Acquire Lock on device Device  (a8dc) 00158d0003677242
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Release Lock on device Device  (a8dc) 00158d0003677242
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Acquire Lock on device Device  (ef99) 00158d0002ad9f71
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Release Lock on device Device  (ef99) 00158d0002ad9f71
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Load success
[2021-01-31 17:57:49][INFO][zigate](MainThread) : Searching ZiGate port
[2021-01-31 17:57:49][INFO][zigate](MainThread) : ZiGate found at /dev/ttyUSB0
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : REQUEST : 0x0018 b'\x00'
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Msg to send b'001800011900'
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Encoded Msg to send b'010210180210021119021003'
[2021-01-31 17:57:49][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0018
[2021-01-31 17:57:50][INFO] : Démon zigate lancé
[2021-01-31 17:57:54][WARNING][zigate](MainThread) : No response after command 0x0018 (1)
[2021-01-31 17:57:54][DEBUG][zigate](MainThread) : REQUEST : 0x0010
[2021-01-31 17:57:54][DEBUG][zigate](MainThread) : Msg to send b'0010000010'
[2021-01-31 17:57:54][DEBUG][zigate](MainThread) : Encoded Msg to send b'01021010021002101003'
[2021-01-31 17:57:54][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0010
[2021-01-31 17:57:59][WARNING][zigate](MainThread) : No response after command 0x0010 (2)
[2021-01-31 17:57:59][WARNING][zigate](MainThread) : Failed to retrieve zigate firmware version
[2021-01-31 17:57:59][DEBUG][zigate](MainThread) : REQUEST : 0x0021 b'\x07\x18\xc8\x00'
[2021-01-31 17:57:59][DEBUG][zigate](MainThread) : Msg to send b'00210004f20718c800'
[2021-01-31 17:57:59][DEBUG][zigate](MainThread) : Encoded Msg to send b'0102102102100214f2021718c8021003'
[2021-01-31 17:57:59][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0021
[2021-01-31 17:58:04][WARNING][zigate](MainThread) : No response after command 0x0021 (3)
[2021-01-31 17:58:04][DEBUG][zigate](MainThread) : REQUEST : 0x0023 b'\x00'
[2021-01-31 17:58:04][DEBUG][zigate](MainThread) : Msg to send b'002300012200'
[2021-01-31 17:58:04][DEBUG][zigate](MainThread) : Encoded Msg to send b'010210230210021122021003'
[2021-01-31 17:58:04][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0023
[2021-01-31 17:58:09][WARNING][zigate](MainThread) : No response after command 0x0023 (4)
[2021-01-31 17:58:09][DEBUG][zigate](MainThread) : Check network state
[2021-01-31 17:58:09][DEBUG][zigate](MainThread) : REQUEST : 0x0009
[2021-01-31 17:58:09][DEBUG][zigate](MainThread) : Msg to send b'0009000009'
[2021-01-31 17:58:09][DEBUG][zigate](MainThread) : Encoded Msg to send b'010210021902100210021903'
[2021-01-31 17:58:09][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0009
[2021-01-31 17:58:14][WARNING][zigate](MainThread) : No response after command 0x0009 (5)
[2021-01-31 17:58:14][ERROR][zigate](MainThread) : Failed to get network state
[2021-01-31 17:58:14][DEBUG][zigate](MainThread) : Network is down, start it
[2021-01-31 17:58:14][DEBUG][zigate](MainThread) : REQUEST : 0x0024
[2021-01-31 17:58:14][DEBUG][zigate](MainThread) : Msg to send b'0024000024'
[2021-01-31 17:58:14][DEBUG][zigate](MainThread) : Encoded Msg to send b'01021024021002102403'
[2021-01-31 17:58:14][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0024
[2021-01-31 17:58:19][WARNING][zigate](MainThread) : No response after command 0x0024 (6)
[2021-01-31 17:58:20][DEBUG][zigate](MainThread) : REQUEST : 0x0009
[2021-01-31 17:58:20][DEBUG][zigate](MainThread) : Msg to send b'0009000009'
[2021-01-31 17:58:20][DEBUG][zigate](MainThread) : Encoded Msg to send b'010210021902100210021903'
[2021-01-31 17:58:20][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0009
[2021-01-31 17:58:25][WARNING][zigate](MainThread) : No response after command 0x0009 (7)
[2021-01-31 17:58:26][DEBUG][zigate](MainThread) : REQUEST : 0x0009
[2021-01-31 17:58:26][DEBUG][zigate](MainThread) : Msg to send b'0009000009'
[2021-01-31 17:58:26][DEBUG][zigate](MainThread) : Encoded Msg to send b'010210021902100210021903'
[2021-01-31 17:58:26][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0009
[2021-01-31 17:58:31][WARNING][zigate](MainThread) : No response after command 0x0009 (8)
[2021-01-31 17:58:32][DEBUG][zigate](MainThread) : REQUEST : 0x0009
[2021-01-31 17:58:32][DEBUG][zigate](MainThread) : Msg to send b'0009000009'
[2021-01-31 17:58:32][DEBUG][zigate](MainThread) : Encoded Msg to send b'010210021902100210021903'
[2021-01-31 17:58:32][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0009
[2021-01-31 17:58:37][WARNING][zigate](MainThread) : No response after command 0x0009 (9)
[2021-01-31 17:58:37][ERROR][zigate](MainThread) : Failed to start network
[2021-01-31 17:58:37][DEBUG][zigate](MainThread) : REQUEST : 0x0011
[2021-01-31 17:58:37][DEBUG][zigate](MainThread) : Msg to send b'0011000011'
[2021-01-31 17:58:37][DEBUG][zigate](MainThread) : Encoded Msg to send b'01021011021002101103'
[2021-01-31 17:58:37][DEBUG][zigate](MainThread) : Auto saving /var/www/html/plugins/zigate/core/class/../../resources/zigated/zigate.json
[2021-01-31 17:58:37][DEBUG][zigate](MainThread) : Saving persistent file
[2021-01-31 17:58:37][DEBUG][zigate](MainThread) : Acquire Lock to save persistent file
[2021-01-31 17:58:38][DEBUG][zigate](MainThread) : Release Lock of persistent file
[2021-01-31 17:58:38][DEBUG][zigate](MainThread) : REQUEST : 0x0010
[2021-01-31 17:58:38][DEBUG][zigate](MainThread) : Msg to send b'0010000010'
[2021-01-31 17:58:38][DEBUG][zigate](MainThread) : Encoded Msg to send b'01021010021002101003'
[2021-01-31 17:58:38][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0010
[2021-01-31 17:58:43][WARNING][zigate](MainThread) : No response after command 0x0010 (10)
[2021-01-31 17:58:43][ERROR][zigate](ZiGate-Listen) : OOPS connection lost, reconnect...
[2021-01-31 17:58:43][DEBUG][root](ZiGate-Listen) : External command ZIGATE_FAILED_TO_CONNECT : {'message': 'Failed to connect, retry in 1 sec...'}
[2021-01-31 17:58:43][ERROR][zigate](ZiGate-Listen) : Failed to connect, retry in 1 sec...
[2021-01-31 17:58:43][DEBUG][zigate](MainThread) : REQUEST : 0x0018 b'\x00'
[2021-01-31 17:58:43][DEBUG][zigate](MainThread) : Msg to send b'001800011900'
[2021-01-31 17:58:43][DEBUG][zigate](MainThread) : Encoded Msg to send b'010210180210021119021003'
[2021-01-31 17:58:43][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0018
[2021-01-31 17:58:43][DEBUG][root](Thread-1) : Send to jeedom :  {'action': 'ZIGATE_FAILED_TO_CONNECT', 'message': 'Failed to connect, retry in 1 sec...'}
[2021-01-31 17:58:43][DEBUG] : Array (     [action] => ZIGATE_FAILED_TO_CONNECT     [message] => Failed to connect, retry in 1 sec... )
[2021-01-31 17:58:43][DEBUG][root](Thread-1) : Jeedom reply :  {'success': True}
[2021-01-31 17:58:48][WARNING][zigate](MainThread) : No response after command 0x0018 (11)
[2021-01-31 17:58:48][DEBUG][zigate](MainThread) : REQUEST : 0x0010
[2021-01-31 17:58:48][DEBUG][zigate](MainThread) : Msg to send b'0010000010'
[2021-01-31 17:58:48][DEBUG][zigate](MainThread) : Encoded Msg to send b'01021010021002101003'
[2021-01-31 17:58:48][DEBUG][zigate](MainThread) : Waiting for status message for command 0x0010
[2021-01-31 17:58:53][WARNING][zigate](MainThread) : No response after command 0x0010 (12)
[2021-01-31 17:58:53][WARNING][zigate](MainThread) : Failed to retrieve zigate firmware version
[2021-01-31 17:58:53][INFO][root](MainThread) : Firmware ZiGate : None
Traceback (most recent call last):
File "/var/www/html/plugins/zigate/core/class/../../resources/zigated/zigated.py", line 336, in <module>
if version < '3.0d':
TypeError: '<' not supported between instances of 'NoneType' and 'str'
12
Translate »