Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

PiZigate No packet received

Bonsoir,

J'ai récemment acheté une PiZigate que j'ai installé avec Jeedom sur une Raspberry pi 2.

Malheureusement pour le moment je n'arrive pas a communiquer avec.

Lorsque je lance l'outil de test, j'obtiens la sortie suivante :

Searching /dev/ttyAMA0...

+ Port : /dev/ttyAMA0 is not used

Verif GPIOs ...

+ GPIO 0 (RESET) --> OK

+ GPIO 2 (FLASH) --> OK

Config GPIOs ...

+ GPIO 0 (RESET) --> OK

+ GPIO 2 (FLASH) --> OK

Opening : /dev/ttyAMA0 ...

+ /dev/ttyAMA0 opened --> OK

- No packet received - size sent : 11 - error : 11

Est ce que quelqu'un aurait une idée d'où pourrait venir ce problème ?

Merci par avance,

Bonne soirée

Bonjour,

cela peut se produire pour 2 raisons:

* la PiZigate n'est pas bien branchée.

* la PiZiGate n'est pas correctement flashée.

Peux-tu essayer de reflasher la ZiGate en suivant la procédure suivante ?

$ gpio mode 0 out
$ gpio mode 2 out
$ gpio write 2 0 
$ gpio write 0 0
$ gpio write 0 1
$ sudo apt-get install git
$ sudo git clone https://github.com/Jerome-PS/JennicModuleProgrammer.git
$ cd JennicModuleProgrammer/
$ cd Build/
$ make
$ wget https://github.com/fairecasoimeme/ZiGate/releases/download/Release/ZiGate_v30f.bin
$ ./JennicModuleProgrammer -V 6 -P 115200 -f ZiGate_v30f.bin -s /dev/ttyAMA0

Bonjour,

Je viens d'essayer de reflasher la ZiGate et j'ai obtenu :

pi@raspberrypi:~/JennicModuleProgrammer/Build $ sudo ./JennicModuleProgrammer -V 6 -P 115200 -f ZiGate_v30f.bin -s /dev/ttyAMA0

JennicModuleProgrammer Version: 0.6 (r56124)

Setting baudrate: 115200

Error setting baudrate

Le message d'erreur est apparu environ 5 minutes après avoir lancé la commande.

J'ai vérifier j'ai bien une raspberry pi 2B revision 1.1.

Voici une photo de mon montage:

Montage PiZigate

Merci beaucoup pour l'aide !

Pouvez-vous, (avant de lancer la commande JennicModuleProgrammer) faire un :

$ gpio readall

et

$ ls -l /dev/tty*

essayez aussi la commande suivante :

$ usermod -a -G dialout /dev/ttyAMA0

 

Fred

 

 

Voici les outputs:

$ gpio readall :

 +-----+-----+---------+------+---+---Pi 2---+---+------+---------+-----+-----+

| BCM | wPi |   Name  | Mode | V | Physical | V | Mode | Name    | wPi | BCM |

+-----+-----+---------+------+---+----++----+---+------+---------+-----+-----+

|     |     |    3.3v |      |   |  1 || 2  |   |      | 5v      |     |     |

|   2 |   8 |   SDA.1 |   IN | 1 |  3 || 4  |   |      | 5v      |     |     |

|   3 |   9 |   SCL.1 |   IN | 1 |  5 || 6  |   |      | 0v      |     |     |

|   4 |   7 | GPIO. 7 |   IN | 1 |  7 || 8  | 1 | ALT0 | TxD     | 15  | 14  |

|     |     |      0v |      |   |  9 || 10 | 1 | ALT0 | RxD     | 16  | 15  |

|  17 |   0 | GPIO. 0 |  OUT | 1 | 11 || 12 | 0 | IN   | GPIO. 1 | 1   | 18  |

|  27 |   2 | GPIO. 2 |  OUT | 0 | 13 || 14 |   |      | 0v      |     |     |

|  22 |   3 | GPIO. 3 |   IN | 0 | 15 || 16 | 0 | IN   | GPIO. 4 | 4   | 23  |

|     |     |    3.3v |      |   | 17 || 18 | 0 | IN   | GPIO. 5 | 5   | 24  |

|  10 |  12 |    MOSI |   IN | 0 | 19 || 20 |   |      | 0v      |     |     |

|   9 |  13 |    MISO |   IN | 0 | 21 || 22 | 0 | IN   | GPIO. 6 | 6   | 25  |

|  11 |  14 |    SCLK |   IN | 0 | 23 || 24 | 1 | IN   | CE0     | 10  | 8   |

|     |     |      0v |      |   | 25 || 26 | 1 | IN   | CE1     | 11  | 7   |

|   0 |  30 |   SDA.0 |   IN | 1 | 27 || 28 | 1 | IN   | SCL.0   | 31  | 1   |

|   5 |  21 | GPIO.21 |   IN | 1 | 29 || 30 |   |      | 0v      |     |     |

|   6 |  22 | GPIO.22 |   IN | 1 | 31 || 32 | 0 | IN   | GPIO.26 | 26  | 12  |

|  13 |  23 | GPIO.23 |   IN | 0 | 33 || 34 |   |      | 0v      |     |     |

|  19 |  24 | GPIO.24 |   IN | 0 | 35 || 36 | 0 | IN   | GPIO.27 | 27  | 16  |

|  26 |  25 | GPIO.25 |   IN | 0 | 37 || 38 | 0 | IN   | GPIO.28 | 28  | 20  |

|     |     |      0v |      |   | 39 || 40 | 0 | IN   | GPIO.29 | 29  | 21  |

+-----+-----+---------+------+---+----++----+---+------+---------+-----+-----+

| BCM | wPi |   Name  | Mode | V | Physical | V | Mode | Name    | wPi | BCM |

+-----+-----+---------+------+---+---Pi 2---+---+------+---------+-----+-----+

$ ls -l /dev/tty*

crw-rw-rw- 1 root tty    5,  0 Apr 14 11:01 /dev/tty

crw--w---- 1 root tty    4,  0 Apr 14 11:01 /dev/tty0

crw--w---- 1 root tty    4,  1 Apr 14 11:01 /dev/tty1

crw--w---- 1 root tty    4, 10 Apr 14 11:01 /dev/tty10

crw--w---- 1 root tty    4, 11 Apr 14 11:01 /dev/tty11

crw--w---- 1 root tty    4, 12 Apr 14 11:01 /dev/tty12

crw--w---- 1 root tty    4, 13 Apr 14 11:01 /dev/tty13

crw--w---- 1 root tty    4, 14 Apr 14 11:01 /dev/tty14

crw--w---- 1 root tty    4, 15 Apr 14 11:01 /dev/tty15

crw--w---- 1 root tty    4, 16 Apr 14 11:01 /dev/tty16

crw--w---- 1 root tty    4, 17 Apr 14 11:01 /dev/tty17

crw--w---- 1 root tty    4, 18 Apr 14 11:01 /dev/tty18

crw--w---- 1 root tty    4, 19 Apr 14 11:01 /dev/tty19

crw--w---- 1 root tty    4,  2 Apr 14 11:01 /dev/tty2

crw--w---- 1 root tty    4, 20 Apr 14 11:01 /dev/tty20

crw--w---- 1 root tty    4, 21 Apr 14 11:01 /dev/tty21

crw--w---- 1 root tty    4, 22 Apr 14 11:01 /dev/tty22

crw--w---- 1 root tty    4, 23 Apr 14 11:01 /dev/tty23

crw--w---- 1 root tty    4, 24 Apr 14 11:01 /dev/tty24

crw--w---- 1 root tty    4, 25 Apr 14 11:01 /dev/tty25

crw--w---- 1 root tty    4, 26 Apr 14 11:01 /dev/tty26

crw--w---- 1 root tty    4, 27 Apr 14 11:01 /dev/tty27

crw--w---- 1 root tty    4, 28 Apr 14 11:01 /dev/tty28

crw--w---- 1 root tty    4, 29 Apr 14 11:01 /dev/tty29

crw--w---- 1 root tty    4,  3 Apr 14 11:01 /dev/tty3

crw--w---- 1 root tty    4, 30 Apr 14 11:01 /dev/tty30

crw--w---- 1 root tty    4, 31 Apr 14 11:01 /dev/tty31

crw--w---- 1 root tty    4, 32 Apr 14 11:01 /dev/tty32

crw--w---- 1 root tty    4, 33 Apr 14 11:01 /dev/tty33

crw--w---- 1 root tty    4, 34 Apr 14 11:01 /dev/tty34

crw--w---- 1 root tty    4, 35 Apr 14 11:01 /dev/tty35

crw--w---- 1 root tty    4, 36 Apr 14 11:01 /dev/tty36

crw--w---- 1 root tty    4, 37 Apr 14 11:01 /dev/tty37

crw--w---- 1 root tty    4, 38 Apr 14 11:01 /dev/tty38

crw--w---- 1 root tty    4, 39 Apr 14 11:01 /dev/tty39

crw--w---- 1 root tty    4,  4 Apr 14 11:01 /dev/tty4

crw--w---- 1 root tty    4, 40 Apr 14 11:01 /dev/tty40

crw--w---- 1 root tty    4, 41 Apr 14 11:01 /dev/tty41

crw--w---- 1 root tty    4, 42 Apr 14 11:01 /dev/tty42

crw--w---- 1 root tty    4, 43 Apr 14 11:01 /dev/tty43

crw--w---- 1 root tty    4, 44 Apr 14 11:01 /dev/tty44

crw--w---- 1 root tty    4, 45 Apr 14 11:01 /dev/tty45

crw--w---- 1 root tty    4, 46 Apr 14 11:01 /dev/tty46

crw--w---- 1 root tty    4, 47 Apr 14 11:01 /dev/tty47

crw--w---- 1 root tty    4, 48 Apr 14 11:01 /dev/tty48

crw--w---- 1 root tty    4, 49 Apr 14 11:01 /dev/tty49

crw--w---- 1 root tty    4,  5 Apr 14 11:01 /dev/tty5

crw--w---- 1 root tty    4, 50 Apr 14 11:01 /dev/tty50

crw--w---- 1 root tty    4, 51 Apr 14 11:01 /dev/tty51

crw--w---- 1 root tty    4, 52 Apr 14 11:01 /dev/tty52

crw--w---- 1 root tty    4, 53 Apr 14 11:01 /dev/tty53

crw--w---- 1 root tty    4, 54 Apr 14 11:01 /dev/tty54

crw--w---- 1 root tty    4, 55 Apr 14 11:01 /dev/tty55

crw--w---- 1 root tty    4, 56 Apr 14 11:01 /dev/tty56

crw--w---- 1 root tty    4, 57 Apr 14 11:01 /dev/tty57

crw--w---- 1 root tty    4, 58 Apr 14 11:01 /dev/tty58

crw--w---- 1 root tty    4, 59 Apr 14 11:01 /dev/tty59

crw--w---- 1 root tty    4,  6 Apr 14 11:01 /dev/tty6

crw--w---- 1 root tty    4, 60 Apr 14 11:01 /dev/tty60

crw--w---- 1 root tty    4, 61 Apr 14 11:01 /dev/tty61

crw--w---- 1 root tty    4, 62 Apr 14 11:01 /dev/tty62

crw--w---- 1 root tty    4, 63 Apr 14 11:01 /dev/tty63

crw--w---- 1 root tty    4,  7 Apr 14 11:01 /dev/tty7

crw--w---- 1 root tty    4,  8 Apr 14 11:01 /dev/tty8

crw--w---- 1 root tty    4,  9 Apr 14 11:01 /dev/tty9

crwxrwxrwx 1 root tty  204, 64 Apr 14 11:09 /dev/ttyAMA0

crw------- 1 root root   5,  3 Apr 14 11:01 /dev/ttyprintk

$ usermod -a -G dialout /dev/ttyAMA0:

usermod: user '/dev/ttyAMA0' does not exist

Suite à cela j'ai ajouté le user pi au group dialout (et par la suite au groupe tty) mais le problème persiste :/

Bonsoir,

J'ai le même problème avec les mêmes résultats.

Si quelqu'un a une solution je suis aussi preneur.

Merci d'avance.

Avez-vous bien suivi le tuto qui est ici: https://zigate.fr/documentation/compatibilite-raspberry-pi-3-et-zero-w/

Oui, j'ai bien suivi le tuto. j'ai fait la même chose que gaétan et j'ai le même resultat.

Par contre j'ai un raspberry première génération (B).

bonjour,

j'ai aussi le même problème et exactement les mêmes résultats (mais c'est immédiat chez moi ^^)

comment savoir si les modifs sont bien effectuées (celles spécifiques au 3 et celles de prod / flash) ? mon Pi n'a aucune led bleue (comme indiqué dans la doc), j'ai un Pi 3

je cherchais le moyen de mettre à jour (la doc est prévue pour la version externe en USB), faut-il entrer en mode flash ?

merci

 

EDIT : ce matin, j'ai redémarré, je n'ai pas mis le mode flash (qui me semble ne pas être utile) et j'obtiens :

./PiZiGate_test /dev/ttyAMA0
Searching /dev/ttyAMA0...
+ Port : /dev/ttyAMA0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyAMA0 ...
+ /dev/ttyAMA0 opened --> OK
- No packet received - size sent : 11 - error : 11

Bonjour,

j'ai le même problème (No packet received - size sent : 11 - error : 11) lors du test de la PiZiGate après installation de JEEDOM

J'ai suivi toutes les étapes pour l'installation, la compatibilité , le flash OK avec la procédure au dessus (ICI)

j'ai ouvert un post ICI semaine dernière avec plus de détails sur ce que j'ai fait et les résultats.

en espérant que quelqu'un pourra nous aider,

merci

19/05/19 : nouveau test en repartant à zéro
je viens de poster le résultat ICI

Translate »