Vous devez vous identifier pour créer des messages et des sujets.

Pb installation PiZiGate sous JEEDOM

12

Bonjour,

j'ai acquis une PiZiGate tout dernièrement
pour son installation, je suis reparti d'une installation complète de RASPBIAN dernière version sur un Raspberry Pi Carte Mère 3 Model B Quad Core CPU 1.2 GHz 1 Go RAM
après installation de RASPBIAN dernière version, j'ai suivi les modifications à faire pour la compatibilité de la PiZiGate et ensuite son paramétrage.

Lors de l'installation de JEEDOM en repartant à zéro, j'ai testé avec les deux plugin :
Plugin ZiGate,
toute l'installation se passe bien sur /dev/ttyAMA0, les dépendances sont installées et le démon lancé
Le mode inclusion fait bien clignoter la lampe bleue, mais rien se se passe quand je lance la procédure dedetection d'un module AQARA.

Plugin Abeille :
j'ai testé le plugin Abeille et me rend compte que mes module AQARA (2 detecteurs d'ouverture et un detecteur de température) sont reconnus, mais pas dans JEEDOM grace au graph du réseau.
mais rien en mode inclusion

j'ai réalisé le test de la PiZiGate, en dessous, le résultat.
pi@raspberrypi3:~/Downloads/PiZiGate/Test $ ./PiZiGate_test /dev/ttyAMA0
Searching /dev/ttyAMA0...
+ Port : /dev/ttyAMA0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyAMA0 ...
+ /dev/ttyAMA0 opened --> OK
- No packet received - size sent : 11 - error : 11

Avant l'installation du plugin dans JEEDOM, j'avais le résultat suivant :
Packet received --> OK
Release : 1100
Version : 0301

il n'y a rien d'autre d'installé ou de branché sur mon Raspberry

Quelqu'un peut il m'aider ?

Merci d'avance

Bonjour,

test à nouveau aujourd'hui en repartant à zéro
à chaque étape, j'ai fait le tests Zigate et le résultat est le suivant :
après installation JEEDOM : test ZIGATE OK
après lancement JEEDOM OK
après installation plugin ZIGATE sans activation : OK
après activation : OK
installation des dépendances : OK
choix du port dans plugin : KO --> error 11

comme vous pouvez le voir, tout est correct jusqu'à la sélection du port dans JEEDOM. à ce moment là; j'ai l'erreur 11 qui apparaît.

Est ce un problème matériel comme l'indique le poste ICI ?

Cela fait plusieurs semaines que je tente de la faire fonctionner sans succès.

Merci pour votre aide

Bonjour,

Le premier post indique que côté matériel, tout à l'air OK. Puis l'installation du plugin semble avoir mis la pagaille.

Il est important de ne pas avoir de conflit entre le plugin et d'autres utilisation/application.

Il me semble que le plugin Abeille configure lors du démarrage le passage de la PiZiGate en mode production. Il ne faut donc pas créer le fichier rc.local avec le paramétrage des GPIOs.

Fred.

 

Salut,

Je reste aussi sans réponse.

j'ai un raspberry première génération (B)

en mode production à savoir :

gpio mode 0 out
gpio mode 2 out
gpio write 2 1
gpio write 0 0
gpio write 0 1

 

J'obtiens pour le test:

Searching /dev/ttyAMA0...
sh: 1: lsof: not found
+ Port : /dev/ttyAMA0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyAMA0 ...
+ /dev/ttyAMA0 opened --> OK
- No packet received - size sent : 11 - error : 11

 

Pour le flashage:

JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Error setting baudrate

En mode flashage:

Searching /dev/ttyAMA0...
sh: 1: lsof: not found
+ Port : /dev/ttyAMA0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
- GPIO 2 (FLASH) --> NOK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyAMA0 ...
+ /dev/ttyAMA0 opened --> OK
- No packet received - size sent : 11 - error : 11

Pour le flashage:

JennicModuleProgrammer Version: 0.6 (r56124)
Setting baud rate: 115200
Error setting baudrate

 

 

 

Bonjour,

merci pour votre réponse.
pour mon dernier test, je n'ai utilisé que le plugin ZiGate.
je ne pense pas qu'il y ait de conflit car sur mon raspberry de test, il n'y a rien d'autre d'installé.
seulement JEEDOM et le montage d'une cle USB pour le programme de test
--> Je repars à chaque fois à zéro pour éviter ces problèmes de conflits

j'ai remplacé le plugin Zigate par le plugin Abeille en suivant votre conseil pour le paramétrage des GPIOs.
le résultat est mieux car lors de l'inclusion, la lampe clignote (ce n'était pas le cas avant), mais toujours pas d'inclusion possible.

Je suis donc toujours avec le même problème et même message d'erreur lors du test

Citation de domotique le 20 mai 2019, 11 h 17 min

Salut,

Je reste aussi sans réponse.

j'ai un raspberry première génération (B)

en mode production à savoir :

gpio mode 0 out
gpio mode 2 out
gpio write 2 1
gpio write 0 0
gpio write 0 1

 

J'obtiens pour le test:

Searching /dev/ttyAMA0...
sh: 1: lsof: not found
+ Port : /dev/ttyAMA0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyAMA0 ...
+ /dev/ttyAMA0 opened --> OK
- No packet received - size sent : 11 - error : 11

 

Pour le flashage:

JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Error setting baudrate

En mode flashage:

Searching /dev/ttyAMA0...
sh: 1: lsof: not found
+ Port : /dev/ttyAMA0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
- GPIO 2 (FLASH) --> NOK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyAMA0 ...
+ /dev/ttyAMA0 opened --> OK
- No packet received - size sent : 11 - error : 11

Pour le flashage:

JennicModuleProgrammer Version: 0.6 (r56124)
Setting baud rate: 115200
Error setting baudrate

 

 

 

Bonjour,

je vous conseille d'installer lsof qui vous permettra de voir si votre port série est déjà utilisé.

Pour cela, faites :

$ sudo apt-get install lsof

Puis, refaites le test.

Fred

Citation de didnat33 le 20 mai 2019, 13 h 52 min

Bonjour,

merci pour votre réponse.
pour mon dernier test, je n'ai utilisé que le plugin ZiGate.
je ne pense pas qu'il y ait de conflit car sur mon raspberry de test, il n'y a rien d'autre d'installé.
seulement JEEDOM et le montage d'une cle USB pour le programme de test
--> Je repars à chaque fois à zéro pour éviter ces problèmes de conflits

j'ai remplacé le plugin Zigate par le plugin Abeille en suivant votre conseil pour le paramétrage des GPIOs.
le résultat est mieux car lors de l'inclusion, la lampe clignote (ce n'était pas le cas avant), mais toujours pas d'inclusion possible.

Je suis donc toujours avec le même problème et même message d'erreur lors du test

Si la LED bleue clignotte lors de l'inclusion, c'est que la ZiGate fonctionne. Donc plus besoin de faire le test. Le plugin Abeille gère la PiZiGate et occupe le port série. Il y a conflit entre le plugin et l'outil de test. Je ne suis pas sur, non plus, mais il me semble que le plugin ZiGate s'occupe aussi de gérer la PiZiGate.

Lorsque l'on lance l'application de test, il faut désactiver les plugins Jeedom.

Fred

Bonsoir,

pour le plugin Abeille, je confirme qu'il faut pas mettre les ports dans le fichier "/etc/rc.local".
pour le plugin Zigate, il le faut.

malgré cela, toujours aucune inclusion possible avec mes 3 appareils.
qu'un soit défectueux, mais 3, avouez que ce serait de la malchance.

Dans mon JEEDOM, il n'y a rien d'autre, donc pas de pagaille entre les plugins

existe t'il un moyen d'inclure un appareil en manuel ?
lors de mes tests avec le plugin ABEILLE, j'ai pu voir qu'ils étaient visible avec un identifiant

Merci pour votre aide

Bonjour,

Pouvez-vous télécharger et tester le nouvel outil de test PiZiGate pour comprendre votre problème ?

https://github.com/fairecasoimeme/PiZiGate-tools/releases

Fred.

Bonjour,

je viens de faire le test, en dessous le résultat

RPI Model searching ...
Warning !!! you must modify /boot/config.txt
Verifying /boot/cmdline.txt ...
+ /boot/cmdline.txt seems to be OK
Verifying /boot/config.txt ...
You have to add enable_uart=1 in /boot/config.txt

il semble nécessaire de modifier le fichier config.
faut t'il faire quelque chose avant de le lancer ?

merci

 

12
Translate »