Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Fil d’Ariane du forum – Vous êtes ici :Forum de la ZiGatePiZiGate: HardwareUpdate firmware
Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

Update firmware

Bonjour,

Je viens d'acheter un Pizigate que j'ai reçu en version 3.1a. J'ai vu que la 3.1b était récemment sorti.

J'aurai besoin de précisions au sujet de l'upgrade de firmware. Le firmware est-il commun à tous les zigates ou faut il une version spéciale Pizigate ? Si version spécial, ou peut-on la trouver ?

Comme indiqué j'ai récupéré et compilé JennicModuleProgrammer.

Je passe la Zigate en mode flash avec le script suivant :

#!/bin/bash
gpio mode 0 out
gpio mode 2 out
gpio write 2 0
gpio write 0 0
gpio write 0 1

Ensuite, j'utilise la commande suivante :

./JennicModuleProgrammer -V 255 -P 115200 /var/tmp/ZiGate_v3.1b.bin -s /dev/ttyAMA0

Mais rien ne se passe et au bout d'un moment j'ai l'erreur suivante : Error setting baudrate

Pouvez vous m'aider ?

Merci d'avance,

Gael

Bonjour,

Le firmware est commun à tous les produits ZiGate

Avez-vous désactivé le plugin que vous utilisez ?

Il faut relancer la procédure de mode flash (les gpio) avant chaque lancement de la commande de mise à jour.

Fred

Bonjour,

Désolé pour ce retour tardif , j'ai du rater la notification de réponse.

Alors oui, j’exécute bien à chaque fois mon script bash qui contient :

#!/bin/bash
gpio mode 0 out
gpio mode 2 out
gpio write 2 0
gpio write 0 0
gpio write 0 1

De mémoire j'avais arrêté domoticz, donc le plugin devez l’être aussi ? A moins que j'ai raté une étape ?

Si il n'y a pas de contre-indication, je vais re-essayer avec la 3.1c.

Cordialement,

Translate »