Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

transformer pizigate en zigate wifi

bonjour,

je voudrais transformer une pizigate sur pi zero w en zigate wifi et que l'ensemble reste transparent pour jeedom.

Quel peut etre la methode la plus simple pour faire cela ?

merci

Bonjour,

Pour cela, il faut que votre PiZéro redirige tout le trafic série vers l'interface wifi TCP:9999 et inversement.

Peut-être regarder autour de socat ou ser2net (de mémoire)

Fred

merci.

j'ai installé socat mais j'arrive pas à trouver la commande pour rediriger le trafic. J'ai essayé :

sudo socat -v /dev/ttyAMA0 tcp-connect:localhost:9999

sudo socat PTY,link=/dev/ttyAMA0 TCP:127.0.0.1:9999

mais ca ne marche pas, j'ai un message "Connection refused"

Quel est la bonne syntaxe ? Faut il préciser la vitesse du port serie ?

Bonjour,

je n'ai pas encore tester cette solution mais je pense que la commande est plus dans ce style :

sudo socat /dev/ttyAMA0,b115200,raw,echo=0 TCP:127.0.0.1:9999

J'ai trouvé ça aussi :
https://techtinkering.com/2013/04/02/connecting-to-a-remote-serial-port-over-tcpip/

Fred

Bonjour,

Je souhaite également utiliser la PiZiGate sur un Pi Zero pour un branchement sur mon RPI /Jeedom soit par le port USB soit (mieux) par le WiFi.

J'ai suivi les tutos et obtiens un test conforme sur les GPIO et ai pu faire une mise à jour en 3c sans aucun problème particulier. Config.txt et cmdline.txt conformes.

La led eclaire fort mais il semble queje n'ai aucune communication avec la Zigate tout du moins vers l'exterieur.

Je pense que l'option  zigate-ethernet serait la plus judicieuse pour cette utilisation.

Par contre il semble que je rencontre un problème que je ne sais pas résoudre.

Aprés installation de socat :

pi@raspberrypi:~/PiZiGate-tools/test $ sudo socat /dev/ttyAMA0,b113200,raw,echo=0 TCP:127.0.0.1:9999 -vvv
2020/09/01 10:33:52 socat[2032] E exactly 2 addresses required (there are 3); use option "-h" for help

J'ai utilisé votre suggestion concernant l'adresse Ip mais avec le libellé du tuto j'ai exactement le même résultat qui laisse entrevoir un problème sur le nombre d'adresse et cela dépasse mes compétences Linux.

Pour info, j'ai paramétré une ip fixe via dhcpcd.conf pour le wlan0 par laquelle je me connecte avec Putty en wifi me permettant de faire les manipulations.

Bien sur , ni Jeedom ni Abeille ne se connecte sur cette adresse. (Port ???)

Merci votre aide/suggestions.

Bernard

Bonjour,

désolé de relancer le sujet mais je voudrait également utiliser un pi zero comme passerelle zigate-wifi pour pouvoir le lier à mon jeedom.

Pour se faire, j'ai tenté la méthode:

sudo socat /dev/ttyAMA0,b115200,raw,echo=0 TCP:127.0.0.1:9999

Mais j'ai un message de refus de connexion.
Je serai pas contre un peu d'aide.
Merci

Bonjour,

Normalement, vous avez tout ce qu'il faut ici :

Créer une passerelle ZiGate-Ethernet avec un Raspberry Pi

Fred

Bonjour,

en effet, ça a bien fonctionné après avoir rentré le bon paramétrage dans socat.

sudo socat /dev/ttyAMA0,b115200,raw,echo=0 tcp4-listen:9999
et non pas
sudo socat /dev/ttyAMA0,b115200,raw,echo=0 TCP:127.0.0.1:9999

Je suis actuellement sous jeedom. Celui-ci semble bien reconnaitre la passerelle par contre lorsque je veux appairer des appareil, rien n'est détecté (un capteur de mouvement aqara et une ampoule ikea) alors que la led bleue clignote.

J'ai testé avec les 3 plugin actuellement existant à savoir: Zigate, Abeille et Zigbee.

J'ai posé la question sur le forum, on verra bien la réponse.

Merci en tout cas de ta réponse

[EDIT] Bon, après quelques pérégrinations, j'ai enfin réussi à inclure des modules sous jeedom. Je me suis rendu compte qu'en fait le pi0 n'était plus joignable en ssh... du coup hard-reboot. Pour être plus précis, je me rend compte que le pi0 n'est pas stable dans le temps... J'ai changé d'alimentation, passé d'un 5V-2A à un 5V-3A et là c'est fonctionnel... à voir si c'est plus stable dans le temps

 

Merci pour le retour.

Fred

Bonjour,

j'ai eu une remarque à propos du PI0 + zigate sur le forum de jeedom et qui peut avoir son importance. Je la replace ici afin que d'autres utilisateurs soient au courant:

 

Bonjour,
Attention avec le PI0 en wifi si il est sous Buster. il semble que le wifi se met en sommeil et que par conséquent si l’on utilise des commandes avec CRON, pas de réponse quand on en a besoin.Je n’ai pas d’explication mais après de nombreux essais je suis repassé sous Stretch et plus aucun problème. Le travail avec SSH était également très ralenti, voir parfois impossible. Pour info, essais effectués avec plusieurs PI et différentes cartes SD (alim simple chargeur téléphone standard 1A) même avec la ZIgate et connexion avec Jeedom par Jeelink…

Translate »