Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

Rpi 4 + pizigate + jeedom

Bonjour,

Je rencontre un problème, je n'arrive pas a faire fonctionné la pizigate sur jeedom avec mon rpi4.

J'ai suivi cela:

https://zigate.fr/documentation/compatibilite-raspberry-pi-4-b/

Ci-dessous le contenu de mon fichier "config.txt"

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

enable_uart=1

Ci dessous le contenu de mon fichier "cmdline.txt"

usb-storage.quirks=152d:1561:u console=tty1 root=PARTUUID=088d26b6-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles

J'ai ensuite suivie cela:

https://zigate.fr/documentation/parametrer-la-pizigate/

puis effectué la procédure de test:

Apres avoir taper la commande: "./PiZiGate_test /dev/ttyAMA0" j'obtient cela:

pi@raspberrypi:~/ZiGate/Tools/PiZiGate/Test/Bin $ ./PiZiGate_test /dev/ttyAMA0
Searching /dev/ttyAMA0...
+ Port : /dev/ttyAMA0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyAMA0 ...
+ /dev/ttyAMA0 opened --> OK
- No packet received - size sent : 0 - error : 13

J'ai également tapper la commande: "/PiZiGate_test /dev/ttyS0" et j'obtiens cela:

pi@raspberrypi:~/ZiGate/Tools/PiZiGate/Test/Bin $ ./PiZiGate_test /dev/ttyS0
Searching /dev/ttyS0...
+ Port : /dev/ttyS0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyS0 ...
+ /dev/ttyS0 opened --> OK
+ Packet received --> OK
Release : 0b00
Version : 0301

Enfin j'ai test la commande suivante: "./PiZiGate_test /dev/serial0" et j'obtiens cela:

pi@raspberrypi:~/ZiGate/Tools/PiZiGate/Test/Bin $ ./PiZiGate_test /dev/serial0
Searching /dev/serial0...
+ Port : /dev/serial0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/serial0 ...
+ /dev/serial0 opened --> OK
+ Packet received --> OK
Release : 0b00
Version : 0301

Les port serial0 et ttys0 semble donc OK.

Donc 1ere question, quel est le port qu'il faut utilisé dans le plugin (abeille) sur jeedom pour communiqué avec la pizigate?

Et surtout dans le menu déroulant pour sélectionné le port tty je n'ai rien, es-ce normal?

 

Merci d'avance pour votre aide

 

 

 

 

 

Salut,

 

Configuré d'abord dans l'onglet Zigate.

Translate »