Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

Probleme de Pizigate (hard ?) apres installation firmware 3.1d

Bonjour

Je me permet d'écrire sur le forum car âpres un essai de mise à jour du firmware de ma pizigate (en 3.1d), celle-ci ne fonctionne plus du tout, et j’aimerais débloqué ce problème.

J’utilise :

  • Un Raspberry 4
  • Raspbian
  • Une pizigate qui a tres bien marché jusque là

Pour disposer du dernier firmware et donc de la compatibilité avec les nouveaux équipement:

j’ai reprogrammé le firmware avec la version 3.1d (finale) .

J’ai donc essayé avec la ligne de commande :

  • ./JennicModuleProgrammer -V 6 -P 115200 -f "<chemin vers le bin>" -s /dev/ttyAMA0

Mais celle-ci ne fonctionnait pas, pourtant, j’avais bien desactivé domoticz

  • J’ai donc tester avec ./JennicModuleProgrammer -V 6 -P 115200 -f "<chemin vers le bin>" -s /dev/ttyS0

Donc ce cas, la programmation c’est bien passée avec des sucées sur toutes les lignes erasing, writing et veritfying.

Par contre, il indique l'info " Unknow sur Detected Chip "

Il m’est impossible de me connecter au plugin zigate utilisée par domoticz

A partir de là, impossible de contacter la zigate :

  • Les tests de PiziGate_tools sont tous hs sur l'erreur "no packet receive "
  • le plugin domoticz m'affiche les infos
    • "message": "[ 63] I have hard time to get ZiGate Version. Mostlikly ZiGate communication doesn't work",
    • "message": "[   ] Stop the plugin and check ZiGate.",
    • aucune remonté d'info de la version
  • J'ai resinstaller entierement sur une autre carte rasbian et pas d'autre soft , j'ai configurer la carte avec les infos du site pour bien la preparer. rien n'y fait
  • j'ai reinstaller le firwamre plusieurs fois , rien n'y fait
  • j'ai aussi essayer de tester jeedom en esperant débloquer le probleme --> même constat
  • j'ai desactiver le bluetooth --> même constat
  • J'ai remarqué qu'en mode "production" la led bleu s'éclaire plus fortement mais n'est pas stable comme avant, son intensité varie comme si elle clignote très rapidement.

 

Voilà, je me permet d'écrire sur ce forum car je sèche complétement et ne sais que faire de plus.

Cordialement,

Alexandre.

 

Bonjour,

Déjà répondu par mail mais si vous arrivez à flasher et mettre à jour votre PiZiGate c'est matériellement tout fonctionne.

Dans domoticz, il faut sélectionner le bon port /dev/ttyS0 dans votre cas.

Fred

Bonjour,

Effectivement et merci pour votre retour.

Bien sur , j'ai sélectionner le port /dev/ttySo, comme vous me l'avez conseillé.

ou serial0, j'ai bien constaté le lien symbolique entre serial0 et ttyso.

Toutefois, de mon coté, je ne puis enlever l'hypothese de la panne materiel.

Pourquoi ?

Suite à mes tests qui excluent définitivement domoticz.

le premier test étant un formatage de la SD et une réinstallation de Raspbian. Ensuite, configuration et exécution de PiZiGate-tools uniquement. Donc j’exclue complétement domoticz. J'ai re-excuter plusieurs fois cette méthode avec formattage complet. résultat KO

Le deuxième test inclue jeedom et exclue toujours domoticz. Et dans ce cas Jeedom semble incapable de tester correctement l'équipement sur le port série ttyS0.  résultat KO

Mais je ne perds pas espoirs, j'ai un 3 eme test en tête 🙂 --> Je compte tester votre carte sur un autre raspberry, cette fois sur la version 2. Car si votre carte ne pose pas de problème, domoticz non plus, il reste la possibilité du rasp.

En parallèle, j'ai bien sur ouvert un ticket sur le forum domoticz comme vous l'avez conseillé

https://easydomoticz.com/forum/viewtopic.php?f=8&t=11091

Voilà les raisons qui me poussent vers le matériel, le firmware peut être correctement chargé mais la réception des données corrompus, court-circuité ?

Amicalement,

Alexandre.

3 eme test avec un rasp pi 2 ! qui lui n'as pas de bluetooth qui pourrait gêner le port série.

config gpio :

gpio version: 2.50
Copyright (c) 2012-2018 Gordon Henderson
This is free software with ABSOLUTELY NO WARRANTY.
For details type: gpio -warrantyRaspberry Pi Details:
Type: Pi 2, Revision: 01, Memory: 1024MB, Maker: Sony
* Device tree is enabled.
*--> Raspberry Pi 2 Model B Rev 1.1
* This Raspberry Pi supports user-level GPIO access.

 

Config série : si j'ai bien compris, il n'y qu'un lien vers l'UART car pas de BLE intégré au UART du rasp pi2 donc serial0 et ttyAMAo.

pi@raspberrypi:/dev $ ls -l |grep serial
lrwxrwxrwx 1 root root 7 févr. 9 21:18 serial0 -> ttyAMA0

 

test de la carte :

pi@raspberrypi:~/PiZiGate-tools/test $ sudo ./PiZiGate_test /dev/ttyAMA0
RPI Model searching ...
All it's OK
Verifying /boot/cmdline.txt ...
+ /boot/cmdline.txt seems to be OK
Searching /dev/ttyAMA0...
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
+ Port : /dev/ttyAMA0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/ttyAMA0 ...
+ /dev/ttyAMA0 opened --> OK
+ Packet 01 02 10 10 02 10 02 10 10 03 sent --> OK
- No packet received - size sent : 11 - error : 11

 

Conclusion : erreur toujours présente.

 

 

Bonjour Monsieur Zigate,

Je vous ai envoyé un mail avec une proposition pour le dépannage de la pizigate.

Zigatement 🙂

Alexandre.

Sujet Clos, PiZiGate opérationnel suite à votre retour Monsieur PiZigate.

 

 

Translate »