Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

Mise à jour 3.1 ̶b̶ c

12

Bonjour,

Nouveau sur ce forum j'ai une PiziGate avec Domoticz.

Tout marchait très bien jusqu'à ma tentative récente de mettre à jour le plugin PiZiGate.

Plugin 4.11.017

Firmware  0.31a

 

J'ai essayé de suivre les instruction de Yannick, c'est à dire :

1.) Arrêt du module Zigate dans Domoticz

2) Installation du programme de MaJ

sudo apt-get install git

sudo git clone https://github.com/Jerome-PS/JennicModuleProgrammer.git

cd JennicModuleProgrammer/

cd Build/

sudo make

3) Téléchargement du firmware

cd ../../

mkdir pizigate_firmwares

cd pizigate_firmwares

wget https://github.com/fairecasoimeme/ZiGate/releases/download/v3.1c/ZiGate_v3.1c.bin

4) Mettre la Pizigate en mode flash :

gpio mode 0 out

gpio mode 2 out

gpio write 2 0

gpio write 0 0

gpio write 0 1

5) Installer la mise à jour :

sudo ../JennicModuleProgrammer/Build/JennicModuleProgrammer -V 6 -P 115200 -f ZiGate_v3.1d.bin -s /dev/serial0

Or cette commande renvoie une erreur?

/JennicModuleProgrammer/Build $ sudo ./JennicModuleProgrammer -V 6 -P 115200 -f ZiGate_v3.1d.bin -s /dev/serial0
JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Error setting baudrate

Merci d'avance à l'âme charitable qui me permettra d'enfin démêler cette histoire de MAJ, le débutant que je suis a perdu plusieurs heures sur les différents forums pour essayer de résoudre ce problème...

 

Bonjour,

Il y a une version 31e disponible ( https://github.com/fairecasoimeme/ZiGate/releases/tag/v3.1e )

Si tu es sous Domoticz, alors via le plugin tu as un petit script dans Tools

sudo Tools/pi-zigate.sh

flash pour passer la zigate en mode flash

sudo Tools/pi-zigate.sh run

pour passer la zigate en mode run

 

Quand tu passes la Zigate en mode flash, la Led bleu doit etre relativement faible. En règle générale le message d'erreur que tu as es souvent lié au fait que la ZiGate n'est pas en mode flash

 

 

Bonjour Pipiche, merci pour ta réponse.

J'ai passé la ZiGate en mode "flash" (LED faible),  téléchargé la V 3.1e et retenté l'opération:

sudo ./JennicModuleProgrammer/Build/JennicModuleProgrammer -V 6 -P 115200 -f ZiGate_v3.1e.bin -s /dev/serial0
JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Error setting baudrate

 

Vois tu d'autres choses qui pourraient causer cette erreur? Merci d'avance

P.S: Merci pour le script pour Domoticz, dois-je le saisir dans la ligne de commande Linux (dans le répertoire où est Domoticz, je suppose) ou existe t-il une ligne de commande dédiée dans Domoticz? (désolé pour la question de grand débutant! )

Bonsoir,

une avancée ce soir, mais blocage au même stade:

 

pi@raspbi:~ $ sudo ./JennicModuleProgrammer/Build/JennicModuleProgrammer -V 6 -P 115200 -f ZiGate_v3.1e.bin -s /dev/serial0
JennicModuleProgrammer Version: 0.6 (r56124)
Setting baudrate: 115200
Detected Chip: Unknown
MAC Address: 00:15:8D:00:02:1E:14:0A
Could not open firmware file

Impossible d'ouvrir le fichier, même avec sudo?

D'avance merci de votre aide

 

Bonjour,

A mon avis, le chemin du binaire n'est pas le bon ou le nom plutôt qu' un problème de droit.

Fred

Bonsoir,

J'ai réinstallé la PiziGate sur le même Raspberry modèle 3B (j'ai bien suivi le tuto sur leur compatibilité).

J'ai encore un "Error setting baudrate", que j'essaie sur "serial0" ou sur "ttyAMA0" ou "ttyUSB0"...

J'ai lu qu'il fallait configurer le port "ttyAMA0" et tenté de le faire, mais cela ne change rien.. Que faire?

D'avance merci

sudo ./JennicModuleProgrammer -V 6 -e -P 115200 -f "/boot/ZiGate_v3.1e.bin" -s /dev/serial0
JennicModuleProgrammer Version: 0.7(r56124)
Setting baudrate: 115200
Error setting baudrate

12
Translate »