Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

[Résolu] Erreur lors du test de la PiZiGate

Bonjour

J'utilise la PiZiGate sur un raspberry 3B depuis plus d'un an avec domoticz sans trop de problèmes.

J'essaie aujourd'hui de passer sur Home Assistant. J'ai donc refait une installation complète mais je n'arrive pas à ajouter la PiZiGate dans Home Assistant, j'ai toujours une erreur "Impossible de se connecter au périphérique ZHA". Pas plus de réussite avec le plugin doudz/homeassistant-zigate qui me renvoie toujours la même erreur dans les log : [zigate] No response after command 0x0010 (29)

Je cherche donc à contrôler m'assurer que l'installation soit conforme. Or, le test PiZiGate_test me renvoie toujours la même erreur :

pi@raspberrypi:~/PiZiGate-tools/test $ sudo ./PiZiGate_test /dev/serial0
RPI Model searching ...
Warning !!! you must modify /boot/config.txt
Verifying /boot/cmdline.txt ...
+ /boot/cmdline.txt seems to be OK
Verifying /boot/config.txt ...
+ /boot/config.txt seems to be OK
Warning !!! if it's not the case, you have to execute the following commands :
sudo systemctl disable hciuart
sudo usermod -aG gpio pi
then reboot the PI
Searching /dev/serial0...
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
Output information may be incomplete.
+ Port : /dev/serial0 is not used
Verif GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Config GPIOs ...
+ GPIO 0 (RESET) --> OK
+ GPIO 2 (FLASH) --> OK
Opening : /dev/serial0 ...
+ /dev/serial0 opened --> OK
+ Packet 01 02 10 10 02 10 02 10 10 03 sent --> OK
- No packet received - size sent : 11 - error : 11

Même erreur avec dev/ttyAMA0

J'ai bien modifié les fichiers config et cmdline, d'ailleurs le test les valide.

Quelqu'un saurait-il m'aider svp ? Merci ! 🙂

Bonjour

Avec l'aide de zigate & pipiche sur d'autres posts, j'ai résolu le problème de la façon suivante.

Merci à eux !

1/ installer la version 0.7 de jennicmoduleprogrammer en suivant le tutoriel de mise à jour, partie linux :

sudo apt-get install wget unzip
sudo wget https://github.com/fairecasoimeme/ZiGate/raw/master/Tools/JennicModuleProgrammer_R07.zip
unzip JennicModuleProgrammer_R07.zip
cd JennicModuleProgrammer/
cd Build/
sudo make

2/ suivre la procédure de mise à jour, en ajoutant l'option -e à la commande :

cd JennicModuleProgrammer/
cd Build/
sudo make

gpio mode 0 out
gpio mode 2 out
gpio write 2 0
gpio write 0 0
gpio write 0 1

sudo ./JennicModuleProgrammer -V 6 -e -P 115200 -f "<chemin vers le bin>" -s /dev/serial0

Après ce flash, le test s'est déroulé correctement 🙂

Translate »