Bienvenue sur le forum de la ZiGate !

Ici, nous échangeons sur les produits ZiGate (matériellement) et les firmware.

Pour que vous puissiez gagner du temps, je vous conseille de visiter, dans un premier temps, les forums et documentations des plugins et box domotique que vous avez choisi :

Jeedom :

Forum : https://community.jeedom.com/
Plugin ZiGate : https://github.com/Jeedom-Zigate/jeedom-plugin-zigate
Plugin Abeille : https://github.com/KiwiHC16/Abeille + http://kiwihc16.free.fr/

Domoticz :

Forum Francophonehttps://easydomoticz.com/forum/viewforum.php?f=28
Forum Anglophonehttps://www.domoticz.com/forum/viewforum.php?f=68
Développeur: @pipiche38 disponible sur keybase.io en chat

EEdomus :

Forum : https://forum.eedomus.com/

Home-assistant :

Plugin : https://github.com/doudz/homeassistant-zigate
Zigpy : https://www.home-assistant.io/integrations/zha/

Veuillez ou S’enregistrer pour créer des messages et des sujets de discussion.

Xiaomi Aqara Opple

Page 1 de 2Suivant

Quelqu'un a déjà tenté d'appairer ce device?
Ça à l'air plutôt intéressant d'avoir autant de boutons sur un espace réduit :

 

https://fr.aliexpress.com/item/4000317337092.html?spm=a2g0o.productlist.0.0.51a42131X0z7AE&algo_pvid=ae40b9f1-636e-4a36-b69d-ccf5d1feaa6b&algo_expid=ae40b9f1-636e-4a36-b69d-ccf5d1feaa6b-6&btsid=502bce80-6074-4857-aa01-da30e63c7265&ws_ab_test=searchweb0_0,searchweb201602_2,searchweb201603_53

 

Si non je suis prêt à le commander pour faire le test.

Oui, nous l'avons intégré sur Domoticz avec le plugin Zigate, par contre je n'ai pas de retour de l'utilisation

 

Kassoum a réagi à ce message.
Kassoum

C'est commandé ! le temps de la livraison et je te fais un retour 🙂

J'ai reçu l’équipement 🙂

Le bouton à l'arrière permet de join voici les logs qui apparaissent.

2020-03-08 11:52:22.534 Status: (Zigate) Device Annoucement ShortAddr: 2f76, IEEE: 04cf8cdf3c75c30d
2020-03-08 11:52:23.140 Status: (Zigate) [-] NEW OBJECT: 2f76 Request Simple Descriptor for Ep: 01
2020-03-08 11:52:23.141 Status: (Zigate) [-] NEW OBJECT: 2f76 Request Simple Descriptor for Ep: 02
2020-03-08 11:52:23.141 Status: (Zigate) [-] NEW OBJECT: 2f76 Request Simple Descriptor for Ep: 03
2020-03-08 11:52:23.141 Status: (Zigate) [-] NEW OBJECT: 2f76 Request Simple Descriptor for Ep: 04
2020-03-08 11:52:23.142 Status: (Zigate) [-] NEW OBJECT: 2f76 Request Simple Descriptor for Ep: 05
2020-03-08 11:52:23.142 Status: (Zigate) [-] NEW OBJECT: 2f76 Request Simple Descriptor for Ep: 06
2020-03-08 11:52:23.644 Status: (Zigate) [-] NEW OBJECT: 2f76 Simple Descriptor EP 01
2020-03-08 11:52:23.646 (Zigate) Decode8043 - Overwrite ProfileID {} with 0104 from Ep: 01
2020-03-08 11:52:23.647 Status: (Zigate) [-] NEW OBJECT: 2f76 ProfileID 0104
2020-03-08 11:52:23.648 (Zigate) Decode8043 - Overwrite ZDeviceID {} with 0104 from Ep: 01
2020-03-08 11:52:23.648 Status: (Zigate) [-] NEW OBJECT: 2f76 ZDeviceID 0105
2020-03-08 11:52:23.649 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster IN Count: 03
2020-03-08 11:52:23.649 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster In 1: 0000 (Basic)
2020-03-08 11:52:23.650 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster In 2: 0003 (Identify)
2020-03-08 11:52:23.650 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster In 3: 0001 (Power Configuration)
2020-03-08 11:52:23.651 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster OUT Count: 04
2020-03-08 11:52:23.651 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster Out 1: 0003 (Identify)
2020-03-08 11:52:23.651 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster Out 2: 0006 (On/Off)
2020-03-08 11:52:23.651 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster Out 3: 0008 (Level Control)
2020-03-08 11:52:23.652 Status: (Zigate) [-] NEW OBJECT: 2f76 Cluster Out 4: 0300 (Colour Control)
2020-03-08 11:52:27.764 (Zigate) checkTOwaitForStatus - Request a reTransmit of Command : 0043/2f7602 (0)
2020-03-08 11:52:27.766 Status: (Zigate) [0] NEW OBJECT: 2f76 Request Model Name
2020-03-08 11:52:27.767 Status: (Zigate) [0] NEW OBJECT: 2f76 Request Attribute for Cluster 0x0300 to get ColorMode
2020-03-08 11:52:32.787 Status: (Zigate) [1] NEW OBJECT: 2f76 Model Name: lumi.remote.b486opcn01
2020-03-08 11:52:32.789 Status: (Zigate) [1] NEW OBJECT: 2f76 Model Name: lumi.remote.b486opcn01
2020-03-08 11:52:32.789 Status: (Zigate) [1] NEW OBJECT: 2f76 Request Attribute for Cluster 0x0300 to get ColorMode
2020-03-08 11:52:32.791 (Zigate) Too early, let's try to get the Model
2020-03-08 11:52:37.808 Status: (Zigate) [2] NEW OBJECT: 2f76 Model Name: lumi.remote.b486opcn01
2020-03-08 11:52:37.811 Status: (Zigate) [2] NEW OBJECT: 2f76 Model Name: lumi.remote.b486opcn01
2020-03-08 11:52:37.812 Status: (Zigate) [2] NEW OBJECT: 2f76 Request Attribute for Cluster 0x0300 to get ColorMode
2020-03-08 11:52:37.813 (Zigate) GetType - Model lumi.remote.b486opcn01 Profile ID : 0104 ZDeviceID : 0105
2020-03-08 11:52:37.813 (Zigate) GetType - Model lumi.remote.b486opcn01 not found with Ep: 01 in DeviceConf. Continue with ClusterSearch
2020-03-08 11:52:37.814 (Zigate) GetType - ClusterSearch return : Voltage/Switch/LvlControl/ColorControl
2020-03-08 11:52:37.815 (Zigate) subtypeRGB_FromProfile_Device_IDs - Model: lumi.remote.b486opcn01, ProfileID: 0104, ZDeviceID: 0105 ColorInfos: None
2020-03-08 11:52:37.815 (Zigate) subtypeRGB_FromProfile_Device_IDs - ProfileID: 0104 ZDeviceID: 0105 Subtype: 7
2020-03-08 11:52:37.816 (Zigate) GetType - Model lumi.remote.b486opcn01 Profile ID : 0104 ZDeviceID : 0105
2020-03-08 11:52:37.817 (Zigate) GetType - Model lumi.remote.b486opcn01 not found with Ep: 02 in DeviceConf. Continue with ClusterSearch
2020-03-08 11:52:37.817 (Zigate) GetType - ClusterSearch return :
2020-03-08 11:52:37.818 (Zigate) GetType - Model lumi.remote.b486opcn01 Profile ID : 0104 ZDeviceID : 0105
2020-03-08 11:52:37.818 (Zigate) GetType - Model lumi.remote.b486opcn01 not found with Ep: 03 in DeviceConf. Continue with ClusterSearch
2020-03-08 11:52:37.818 (Zigate) GetType - ClusterSearch return :
2020-03-08 11:52:37.818 (Zigate) GetType - Model lumi.remote.b486opcn01 Profile ID : 0104 ZDeviceID : 0105
2020-03-08 11:52:37.819 (Zigate) GetType - Model lumi.remote.b486opcn01 not found with Ep: 04 in DeviceConf. Continue with ClusterSearch
2020-03-08 11:52:37.819 (Zigate) GetType - ClusterSearch return :
2020-03-08 11:52:37.819 (Zigate) GetType - Model lumi.remote.b486opcn01 Profile ID : 0104 ZDeviceID : 0105
2020-03-08 11:52:37.819 (Zigate) GetType - Model lumi.remote.b486opcn01 not found with Ep: 05 in DeviceConf. Continue with ClusterSearch
2020-03-08 11:52:37.821 (Zigate) GetType - ClusterSearch return :
2020-03-08 11:52:37.821 (Zigate) GetType - Model lumi.remote.b486opcn01 Profile ID : 0104 ZDeviceID : 0105
2020-03-08 11:52:37.821 (Zigate) GetType - Model lumi.remote.b486opcn01 not found with Ep: 06 in DeviceConf. Continue with ClusterSearch
2020-03-08 11:52:37.822 (Zigate) GetType - ClusterSearch return :
2020-03-08 11:52:37.822 (Zigate) Request a Bind for 2f76/01 on Cluster 0001
2020-03-08 11:52:37.822 (Zigate) Request a Bind for 2f76/01 on Cluster 0006

2020-03-08 11:52:37.822 (Zigate) Request a Bind for 2f76/01 on Cluster 0008
2020-03-08 11:52:37.823 (Zigate) Request a Bind for 2f76/01 on Cluster 0300
2020-03-08 11:52:37.823 (Zigate) Request a Bind for 2f76/01 on Cluster 0000

 

Par contre une fois qu'on se rend dans le menu Setup/Device on ne voit qu'un équippement et il s'agit d'un variateur de couleur:

 

Je m'attendais plutôt à voir 2 "interrupteurs" apparaitre (j'ai une version avec 2 boutons et 4 possibilitées donc)

Voici les logs quand j'enclenche  un des deux boutons :

2020-03-08 12:02:21.296 (Zigate) UpdateDevice - ( Quadrirupteur) 1:On
2020-03-08 12:02:23.708 (Zigate) UpdateDevice - ( Quadrirupteur) 0:Off
2020-03-08 12:02:25.818 (Zigate) UpdateDevice - ( Quadrirupteur) 1:On
2020-03-08 12:02:27.075 (Zigate) UpdateDevice - ( Quadrirupteur) 0:Off

 

Par contre le deuxième bouton c'est plus étrange :

Pour la position ON :

2020-03-08 12:04:02.278 (Zigate) Decode8085 - SQN: c2, Addr: 2f76, Ep: 01, Cluster: 0008, Cmd: 02, Unknown: 02

Pour la position OFF :

2020-03-08 12:04:07.096 (Zigate) Decode8085 - SQN: c3, Addr: 2f76, Ep: 01, Cluster: 0008, Cmd: 02, Unknown: 02

Voici le contenu de DeviceList-2.txt

{'Version': '3', 'ZDeviceName': '', 'Status': 'inDB', 'SQN': '', 'Ep': {'01': {'0000': {}, '0003': {}, '0001': {}, '0006': {}, '0008': {}, '0300': {}, 'ClusterType': {'24': 'ColorControlFull'}}, '02': {'ClusterType': {}}, '03': {'ClusterType': {}}, '04': {'ClusterType': {}}, '05': {'ClusterType': {}}, '06': {'ClusterType': {}}}, 'Heartbeat': '3', 'RIA': '3', 'RSSI': 141, 'Battery': {}, 'Model': 'lumi.remote.b486opcn01', 'MacCapa': '84', 'IEEE': '04cf8cdf3c75c30d', 'Type': 'Voltage/Switch/LvlControl/ColorControl', 'ProfileID': '0104', 'ZDeviceID': '0105', 'App Version': '17', 'Attributes List': {}, 'DeviceType': '', 'HW Version': '1', 'Last Cmds': [], 'LogicalType': '', 'Manufacturer': '', 'Maufacturer Name': '', 'NbEp': '6', 'PowerSource': '', 'ReadAttributes': {'Ep': {'01': {'0000': {'0000': '00', '0001': '00', '0002': '00', '0003': '00', '0004': '00', '0005': '00'}, '0300': {}, '0001': {}, '0006': {}, '0008': {}}}, 'TimeStamps': {'01-0000': 1583664757, '01-0300': 1583664757, '01-0001': 1583664757, '01-0006': 1583664757, '01-0008': 1583664757}}, 'ReceiveOnIdle': '', 'Stack Version': '2', 'Stamp': {'Time': '2020-03-08 11:52:31', 'MsgType': '8102', 'LastSeen': 1583664751}, 'ZCL Version': '3', 'Health': 'Live', 'Capability': ['Reduced-Function Device', 'Main Powered', 'Standard security', 'NwkAddr should be allocated'], 'ConfigSource': '8043', 'Manufacturer Name': 'LUMI', 'ConfigureReporting': {'Ep': {'01': {'0001': {}, '0000': {}, '0006': {}, '0008': {}, '0300': {}}}, 'TimeStamps': {'01-0001': 1583664757, '01-0000': 1583664757, '01-0006': 1583664757, '01-0008': 1583664757, '01-0300': 1583664757}}, 'Bind': {'0300': {'Stamp': 1583664757, 'Phase': 'requested', 'Status': ''}}}

Dans DeviceConf.txt comme indique les logs on ne trouve pas de "remote.b486opcn01"

 

Je suis sur la branche stable du plugin et de domoticz.

Bonjour,

 

Je te propose que tu crés un post sur le forum Domoticz https://easydomoticz.com/forum/viewtopic.php?p=56717 afin qu'on travaille sur ce sujet.

Effectivement celui qui est connu du plugin est la version 6 boutons. Je suppose que tu as un 2 ou 4 boutons ?

Prends la branche beta du plugin, et refait un appairage (il faudra que tu supprimes les widgets qui ont été créés pour repartir de 0).

A priori 6 Widgets de type LvlControl vont etre créés. Je te propose de tester:

- simple click, double click , triple click, long click et voir ce qu'il se passe.

Les logs seront important

 

Merci de ton aide

 

Juste pour documenter, ces nouveaux switch fonctionnent parfaitement avec la Zigate firmware 3.1c

Je n'arrive pas à le faire fonctionner sur Jeedom, des idées?

Citation de pipiche le 1 mai 2020, 12 h 39 min

Juste pour documenter, ces nouveaux switch fonctionnent parfaitement avec la Zigate firmware 3.1c

It's on domoticz or Jeedom where the switch works ok?

domoticz

Bonjour,

j'ai moi aussi à disposition ce nouvel interrupteur, modèle a 6 boutons : WXCJKG13LM

A l'heure actuel il ne semble pas être complètement géré par le coupe Zigate + Jeedom (firmware zigate 3.1c). De plus, lorsque j'inclus ce bouton, il s'associe directement avec ma lampe Aqara Yeelight. Du coup les 2 premiers boutons servent à l'allumage et l'extinction de la lampe, les boutons de la rangée du milieu gèrent l'intensité lumineuse et la dernière rangée n'a aucune action. Et je n'arrive pas à changer ce comportement.

Est-il possible d'améliorer son intégration dans JEEDOM afin de bénéficier des 6 boutons et de toutes les actions associés (click, double click, triple click, long push) ?

Je suis disponible pour debbuguer si nécessaire.

Merci.

Page 1 de 2Suivant
Translate »